Drupal instalacija serverski zahtevi

Ovaj tutorijal obuhvata sledeće teme:

  • Web server
  • PHP
  • Bazu podataka – MySQL

Drupal je u potpunosti kompatibilan sa našim serverima. Ovo su  serverskih zahteva koji su navedeni na Drupalovom zvaničnom sajtu.

Web server

Drupal 8 radi na bilo kojem veb serveru sa verzijom PHP 5.5.9 ili novijom verzijom.

Mi koristimo Apache web server koji je najčešće korišten web server za Drupal veb stranice. Takođe smo implementirali neophodne promene i module tako da Drupal veb stranice mogu bez problema raditi na našim serverima. Omogućili smo dodatak mod_revrite Apache i prilagodili konfiguraciju virtuelnog hosta.

PHP

Drupal 8 zahteva minimalno PHP 5.5.9 za instalaciju i rad, ali se preporučuje PHP7 + da iskoristi prednost brzine i keširanja.

PHP memorijske zahteve mogu značajno da variraju u zavisnosti od modula koji se koriste na vašoj veb lokaciji. Minimalna veličina memorije je 64MB.

PHP produžetak za povezivanje sa izabranom bazom podataka mora biti instaliran i omogućen. Drupal trenutno podržani konektori baze podataka su: mysql , mysqli, i pgsql.

PHP XML ekstenzija (za blogapi, drupal i ping module). Ovo proširenje je podrazumevano omogućeno na svim našim serverima.

Biblioteka slika za PHP kao što je GD biblioteka je potrebna za rad sa slikama (promena veličine slika, slika i imagecache modula).  ImageMagick je takođe podržan.

Baza podataka

Zahtevani server baze podataka je MySQL 5.5.3 / MariaDB 5.5.20 / Percona Server 5.5.8 ili noviji sa InnoDB-om kao primarnim memorijskim mehanizmom.

143

You may also like